Resolved: SiteMaster Service Disruption

Incident Report for Graebert GmbH

Resolved

The site management issue has been resolved. SiteMaster is now fully operational with all features restored.
Posted Mar 15, 2026 - 01:49 UTC

Investigating

We are investigating issues with SiteMaster. Users may experience problems with site management or project coordination. Engineers are reviewing application performance and data synchronization.
Posted Mar 15, 2026 - 01:45 UTC
This incident affected: SiteMaster Küche.