Resolved: Ares Kudo Service Disruption

Incident Report for Graebert GmbH

Resolved

The Ares Kudo platform incident has been resolved. All CAD functionality, file access, and collaboration features have been restored to full operation.
Posted Jun 17, 2026 - 05:04 UTC

Investigating

We are investigating an incident affecting the Ares Kudo platform. Users may experience issues with CAD functionality, file synchronization, or collaboration features. Engineers are analyzing application performance and service health.
Posted Jun 17, 2026 - 05:01 UTC
This incident affected: Ares Kudo.